Spacial Audio are touting for business via email among the users who still use legacy 4.x.x version of SAM Broadcaster.

Just seen a post on the SAM Broadcaster/Spacial forums from a user of the software.

“You are receiving this communication because you are currently licensed for a retired and now legacy version of SAM Broadcaster Pro.

We would like to notify you that from the 1st of April 2017, you will no longer be able to upgrade your license to the latest version and after this date, you would need to purchase a new license at full price if you wish to move to a later operating system than Windows 7.

You should also be aware that this software is not compatible with Windows 8 or later operating systems. If you plan on using an operating system later than Windows 7 then this is your last chance to take advantage of the current upgrade path.

We therefore recommend that you upgrade to the latest version of your product”

I wrote a while back about SAM Broadcaster 4.x.x not being supported on Windows 10

Spacial want to charge people who originally bought SAM 4.x.x ($59.50 for a limited time) to upgrade to the new 2017 version of SAM Broadcaster.

That’s on top of the $299 they paid for the software way back when.

You don’t have to spend $$$ on upgrading SAM Broadcaster, Which lets face it considering they only tend add 1 feature a year it isn’t really good value for money.

You don’t need to pay anything With RadioDJ radio automation software.

RadioDJ free radio automation software

RadioDJ won’t cost you anything and will work on most versions of Windows from XP to Windows 10*

RadioDJ is also free between versions.

We also cannot stress enough just how stable & reliable RadioDJ is compared to really OLD versions of SAM Broadcaster.

RadioDJ is the future of radio automation software…

Whereas SAM Broadcaster 4.x.x is really yesterday’s “Chip Papers”

(*RadioDJ will install & work as long as the OS supports .NET 3.5 or later)

Last updated on: March 26th, 2017
at 15:11 PM Europe/London

Translate »