Altacast: A Dead Plugin!

With the release of RadioDJv2 old plugins from v1.8.2 will now NOT work in v2.0.0

This means the Altacast plugin will also now NOT function with the program.

RadioDJ V2
Read the full article

Last updated on: January 1st, 2018
at 16:27 PM Europe/London

Translate ยป